Troubleshooting the HD 100 Electronic Logging Device

Last Updated: November 13, 2013

Categories: HD 100

NOTE: Please check back as more troubleshooting information will be added frequently.

Installation

Scenario:

Red light is off for more than 3 minutes after connecting the HD 100 to the diagnostic port, indicating no power on the HD 100 device. 

Troubleshooting:

  • Check power connection on the HD 100 device. Ensure the power cable is secured to the truck's diagnostic port and to the HD 100 device. Disconnect, then reconnect both ends of the power cable, making sure the collar on the diagnostic port end of the cable is locked in place.
  • Check that the red light turns on. The red light on the HD 100 device should illuminate within about 20 seconds, indicating that the device is receiving power from the vehicle. 

Scenario:

Nothing appears on the IntelliRoute® TND™ 720 screen.

Troubleshooting:
Make sure your IntelliRoute® TND™ 720 is charged and powered on. 


Scenario:

Yellow or Green lights stay off for more than 3 minutes after connecting the HD 100 to the diagnosic port, indicating Wi-Fi® or Cell are not connecting on the HD 100 device.

Troubleshooting:

  • Make sure your IntelliRoute® TND™ 720 device is charged and within 10 feet of the HD 100 device.
  • Push the Reset button on the side of the HD 100 device.
  • Check the power connection on the HD 100 device. Ensure the power cable is secured to the truck's diagnostic port and to the HD 100 device. Disconnect, then reconnect both ends of the power cable, making sure the collar on the diagnostic port end of the cable is locked in place.
  • Make sure the truck's ignition is on.
  • Restart the ignition.
  • Check that the colored lights on the HD 100 device are on. The colored lights should illuminate within about 20 seconds, indicating that the HD 100 is connected and running properly. 

NOTE: If, after following these steps, the Green Cell light stays off, this may indicate that you are currently located in an area without Cell coverage. If you do not have Cell coverage, you may continue to log on to the HD 100 software with your Driver ID and use the Hours of Service application, provided you have logged in at least once before with that particular Driver ID. Your HD 100 will continue to capture your HOS data, and once you regain Cell connectivity, your HOS data will update on the device and on the Rand McNally connect web portal.


Scenario:

Cannot access the HD 100 software after clicking the HD 100 button from the IntelliRoute® TND™ 720 Home Menu.

Troubleshooting:

  • Make sure your IntelliRoute® TND™ 720 device is within 10 feet of your HD 100 device. 
  • Wait up to 3 minutes for the colored lights on the HD 100 device to illuminate. 
  • Push the Reset button on the side of the HD 100 device. 

Scenario:

Blue light is still off for more than 3 minutes after connecting the HD 100 to the diagnostic port, indicating the JBus is not responding on the HD 100 device.

Troubleshooting:

  • Make sure your truck's ignition is on.
  • Restart the ignition.
  • Restart both the IntelliRoute® TND™ 720 and HD 100 devices. (1) Log off the HD 100 software. (2) Press the Power button on your IntelliRoute® TND™ 720 device. (3) Disconnect the power cable from your HD 100 device. (4) Reconnect the cable to your HD 100 device. 
  • Check that the Blue light on the HD 100 device turns on. The Blue light should illuminate within about 20 seconds, indicating that the device is connected to the vehicle's Engine Control Module (ECM). 

Can't find an answer? Contact Us